Glyphs can't be opened

Are you sure you started up without plug-ins? Perhaps empty out your Plugins folder to make sure.

If yes, it is not related to the updates of the plug-in, but something else that happened on your Mac. Please redownload and reinstall in that case.

Yes, I’ve even been deleting all plugin but still doesn’t work

Does that mean the last option is reinstalling the app?

It might be that it tries to open a file that was previously opened. If you find a file that has (autosave) in its name, move it into a different folder.

unfortunately, there is no file with the name (autosave) in my folder

@mekkablue so I downloaded and reinstall the app but it still shows the same message. I’m so frustrating

The (autosave) file would be next to the file that you had open the last time. It can be in many places.

@GeorgSeifert still doesn’t work i have follow the crashes tutorial. And now after I redownloaded the app and reinstalling Glyphs still can’t be opened.

  • Does it work in a different user?
  • And can you share the first 30 lines of the crash report from the dialog?
  • are you using any system optimizers like antivirus apps or MacCleaner or other system maintenance tools?


  • just now I just tried using a different user and surprisingly glyphs can be opened.
  • now every time I click the “report” button they no longer display crash reports, I don’t know why.
  • I just use AVG AntiVirus

Get rid of it. No other maintenance apps?

Restart your Mac with the shift key held down (deletes caches), then restart a second time.

Okay, I will try it.

@mekkablue It’s still doesn’t work. Even I delete caches manually through Library/Caches. :slightly_frowning_face:

Did you uninstall the antivirus app?
And perhas you can access the crash report through

@mekkablue yes, I do. and this is the crash report

Can you send me the next 10 or so lines of the report.

It seems to be the image frame plug-in. Can you uninstall it?

And how did you start without plug-ins? Which keys did you hold down when you started the app?


This the next 10 or so lines of the report.


I don’t know how to uninstall it because I have deleted all plug-in in a Plugins folder, even I delete & reinstall it the Glyphs.

I holding down Option and Shift when I started the app as the tutorial said. But it’s still doesn’t work.

@GeorgSeifert @mekkablue

So just now I tried to move glyphs app download in different users to my application folder in there. And when I switch to the main user accidentally opened that app in the application folder in the main user and surprisingly the app can be open.

This confusing but whether it’s okay? if later I can use the application as usually in the main user?

Just skyped and it was working again. I believe the modules and the plug-ins needed reinstalling. One way to achieve this is to restart Glyphs multiple times. Another is to:

  1. Uninstall and immediately reinstall every plug-in in Window > Plugin Manager
  2. Reinstall the modules in Glyphs > Preferences > Addons > Modules
  3. Restart Glyphs once
1 Like