Glyphs Crash on opening after install several plug ins

after I install several plug ins the program keep crashing at start. The only message I get is the information OS window: “Glyphs quit unexpectedly”. I restart the computer, download a fresh version of Glyphs but without success.

Does uninstalling the plugins help?

Can you send some crash reports? And what version do you have?

I can’t send any report, It crash before I even can start Glyphs.
I Just erased the plugins and The program start again, thanks.
The version, I’m not sure but I usually install the latest one, even if is not final.
I copy you the plugins I installed:
I’ll install the again one by one trying to find the one that causes the problem

I found the plugin responsible:
None of the others plugins crush the program.

Can you send me the version of the ExtrudeTool that you have?

I download it directly from Glyphs.
The one that is in the “plugins” menu

What Plugins menu?

I think he meant the plugin manager.

Yes, sorry, I mean the “Plugin manager”.

uh oh, what OS version are you on? I wonder if I have some new code in there that doesn’t jive with macOS < 10.12

I just tried it in 10.9 and it worked fine.

I set the deployment target to macOS 10.10 today. Maybe that recompile helped?

But if anyone finds a reproducible bug or can give me a crash report, feel free to ping me or open an issue at

II didn’t see a crash related to your plugin. @FandoFonts what version of Glyphs do you have? And did you send a crash report (the one that comes up when you restart the app. They should show up after you removed the plugin).

It was in a MacBook Pro with MacOs El Capitán. I’ll send the exact version of OS later. Now I’m with another computer.

This sort of thing happened to me after installing one too many plugins. I ended up having to completely uninstall and reinstall Glyphs to correct it. I think there was a bad preference somewhere that wouldn’t go away - I was also using Mackup to manage my system prefs too and something might have gotten choked up in the process. Perhaps try backing up the Glyphs preferences and reinstalling everything:

Library/Application Support/Glyphs

The Os version I’m using is 10.11.3

Completely removing everything is typically not needed, deleting the plugin folder might have solved it.

@FandoFonts What version of Glyphs do you have? If you have the cutting edge version, please try to update and see if the new version fixes this.

I just updated to the new cutting edge version and reinstalled the extrude tool and just work fine. It didn’t crash anymore.

1 Like