Glyphs crashes at exporting with "color layers to svg" enabled

Hi Guys,

Every time I try to export color svg font it keeps crashing. What could be the problem? Other: I also installed Glyphs 3 it’s amazing I can’t wait to explore it! But, after using it once, now it doesn’t open at all. It crashed and then never opens again. Could you please advise?

Thanks so much!
Glyphs Rocks

Can you send me the .glyphs file?


Thank you so much Georg!

The file export fine for me.

But your instance setup doesn’t make much sense.

  1. you don’t have palettes in your masters, so adding a “Color Palette for SVG” parameter doesnt make much sense.
  2. you seen to intend to export a font for each color, too (to layer it in a layout app). The you should remove all custom parameter in those instances.

Thank you Georg!

I have removed unnecessary parameters, but when I want to export svg font, it crashes again. and also, if i wanna try Glyphs 3 it doesn’t open. Last minute on the screenshot, bottom icon bar, it is jumping then disappears. I m not allowed to upload video here but I did a screen recording, and I uploaded to youtube unlisted:

Thanks so much!

I didn’t read carefully. You mean that Glyphs 2 is crashing? I tried Glyphs 3 and that worked fine.
If Glyphs 3 is not opening, you most likely have installed some incompatible plugins. We are working on a fix for that. So for now, remove the plugins.

Yes I was going to do this with Glyphs 3 but after it won’t open I tried old version but no success. I need to export this otf svg font file. Could it be also disk space problem, I am kinda running low on that too… How do I remove plugins from Glyphs 3? In app folder?

Thank you very much!

Plugins are in ~/Application Support/Glyphs 3/Plugin

1 Like

Thank you so much Georg! I removed some new plugins from Glyphs 3 : It works!!!

I love Glyphs 3 and can’t wait to explore it!

Best Wishes and thank you again!