Glyphs crashes on open

I have installed Glyphs 2.6.6. in 2020 on my Mac. Since I’ve updated my Mac OS to Ventura (13+), Glyphs keeps crashing whenever I try to open it. Restarting my Mac and migrating the app on another Mac doesn’t solve the problem, I can’t open Glyphs anymore.

Please read this: Glyphs 2 on Monterey | Glyphs

I tried already and downgraded my Python version to 2.7 and restarted my Mac, no change. App crashes instantly on start.

Delete your Application Support/Glyphs folder. And try again.

Nothing. Glyphs still crashes on start.

Can you send the crash report. The one that comes up directly after the crash. Copy paste the top part of that report here.

Here is my crash report (Translated report on top):
It seems like the system failed to load the Python library (which is intalled). The File /System/Library/Frameworks/Python.framework/Versions/2.7/Python is on my mac, although the crash report tells me “no such file”.

Translated Report (Full Report Below)

Process:               Glyphs [705]
Path:                  /Applications/
Identifier:            com.GeorgSeifert.Glyphs2
Version:               2.6.6 (1352)
Code Type:             X86-64 (Native)
Parent Process:        launchd [1]
User ID:               501

Date/Time:             2023-08-29 11:12:07.4549 +0200
OS Version:            macOS 13.4.1 (22F770820d)
Report Version:        12
Anonymous UUID:        14691E20-6B02-2AE0-F4CD-4048FCA0DB20

Time Awake Since Boot: 100 seconds

System Integrity Protection: enabled

Crashed Thread:        0

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000

Termination Reason:    Namespace DYLD, Code 1 Library missing
Library not loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
Referenced from: <D65FD876-9533-36C1-BEA7-14421F2C0F34> /Applications/
Reason: tried: '/System/Library/Frameworks/Python.framework/Versions/2.7/Python' (no such file), '/System/Volumes/Preboot/Cryptexes/OS/System/Library/Frameworks/Python.framework/Versions/2.7/Python' (no such file), '/System/Library/Frameworks/Python.framework/Versions/2.7/Python' (no such file, not in dyld cache)
(terminated at launch; ignore backtrace)

Thread 0 Crashed:
0   dyld                          	    0x7ff80e70ec42 __abort_with_payload + 10
1   dyld                          	    0x7ff80e728fd7 abort_with_payload_wrapper_internal + 82
2   dyld                          	    0x7ff80e729009 abort_with_payload + 9
3   dyld                          	    0x7ff80e6ad8f0 dyld4::halt(char const*) + 375
4   dyld                          	    0x7ff80e6aab71 dyld4::prepare(dyld4::APIs&, dyld3::MachOAnalyzer const*) + 4526
5   dyld                          	    0x7ff80e6a93bd start + 1805

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000002000209  rbx: 0x0000000000000000  rcx: 0x00007ff7bc7fc468  rdx: 0x00007ff7bc7fc8d0
  rdi: 0x0000000000000006  rsi: 0x0000000000000001  rbp: 0x00007ff7bc7fc4b0  rsp: 0x00007ff7bc7fc468
   r8: 0x00007ff7bc7fc4d0   r9: 0x0000000000000000  r10: 0x0000000000000083  r11: 0x0000000000000246
  r12: 0x0000000000000083  r13: 0x00007ff7bc7fc8d0  r14: 0x0000000000000001  r15: 0x0000000000000006
  rip: 0x00007ff80e70ec42  rfl: 0x0000000000000246  cr2: 0x0000000103990000
Logical CPU:     0
Error Code:      0x02000209 
Trap Number:     133

Binary Images:
       0x103702000 -        0x1038e8fff com.GeorgSeifert.Glyphs2 (2.6.6) <d65fd876-9533-36c1-bea7-14421f2c0f34> /Applications/
       0x103a49000 -        0x103a8ffff org.sparkle-project.Sparkle (1.21.3) <924a9e58-c0d0-3f2e-aca2-12e7f2bbf275> /Applications/
       0x1039f8000 -        0x103a07fff com.flyingmeat.JSTalk (*) <07c23941-2261-3b3b-8e8f-efd67449f002> /Applications/
       0x103b2d000 -        0x103b62fff com.schriftgestaltung.GlyphsKit (*) <357ccc2e-e495-3f92-9286-00df3fe095b1> /Applications/
       0x103d05000 -        0x103db4fff com.schriftgestaltung.GSFontTools (3.0) <bcb62320-72c6-3ca9-9d98-81a7f2a5f39b> /Applications/
       0x1041fc000 -        0x104492fff com.schriftgestaltung.GlyphsCore (2.3.1) <d3a3ede3-cf63-3255-b0a2-eb6da1414c9d> /Applications/
    0x7ff80e6a3000 -     0x7ff80e73b5cf dyld (*) <5db85b72-c63a-3182-91e5-5c942ec30e48> /usr/lib/dyld

External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=178.7M resident=0K(0%) swapped_out_or_unallocated=178.7M(100%)
Writable regions: Total=8468K written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=8468K(100%)

                                VIRTUAL   REGION 
REGION TYPE                        SIZE    COUNT (non-coalesced) 
===========                     =======  ======= 
STACK GUARD                       56.0M        1 
Stack                             8192K        1 
VM_ALLOCATE                          8K        2 
__DATA                            1399K        9 
__DATA_CONST                        20K        1 
__DATA_DIRTY                         7K        1 
__LINKEDIT                       172.3M        7 
__TEXT                            6480K        7 
dyld private memory                260K        2 
shared memory                        4K        1 
===========                     =======  ======= 
TOTAL                            244.3M       32 


Please follow the instructions in the post. Make sure you download the latest version of Glyphs 2:

If your Glyphs 2 crashes at startup, and you cannot access the dialog, then download the latest version here.

YES, a redownload did the job.
Thanks for your patience and your support!

1 Like