Glyphs crashes when hitting CMND+Z twice

Program is up to date on all accounts. How can this be fixed?

Can you try the latest Cutting Edge version? This might already have been fixed.

And have you sent the crash reports? The ones with the Glyphs icon in the dialog.

Please state the version number anyway. Because it is not clear whether you mean the latest stable version or the latest beta.

Hey there thanks for the response. I’m at version 2.4.1 it says program is up to date. I tried the cutting edge version earlier and now I’m not seeing that option. I’ve sent the crash reports every time they have ever popped up and have described the nature of the problem on numerous occasions.

We need the number in parentheses:

I assume you are using 976?

I cannot reproduce it. I tried Cmd-Z twice in various contexts, but could not trigger a crash. Can you describe step-by-step instructions that reliably reproduce the crash? Or is it only happening with one particular file? If the latter, can you send us that file?

The number is 976.

it seems to only be happening in this specific file.

To reproduce the crash on my end. I simply click Cmd-Z twice and the program shuts down. If i click it once that’s fine. I can do more actions, hit Cmd-Z and it works fine. But if I click it two times in a row, instant crash. Has happened for the past three or four hours. It’s quite maddening haha.

Can you make a screencast and send the file (support at this domain)? I really need those reproducible cases to fix this.

Sure. I’m new to glyphs and am not sure how I can screencast or send you the file. What way is easiest?

Making a screencast is easy with QuickTime player. Then upload the file to Dropbox (or similar) and send me a link.

Sorry for the late reply, the problem you see in the video has been happening for months. I’ve tried uninstalling the program and downloading the newest copy. Once I reopen the program after it crashes the program will crash again if I hit Command + Z two or more times. Every now and again, and error message comes up saying the command stopped working but should be working again soon. Or something along that wording.

Did you try the latest cutting edge version? If so, could you send me your file?

That fixed it, thanks.