Glyphs crashes when using transformations + cursify won't work

Glyphs 3.0.5 (3125) crashes when I want to use the transformations panel. Plus the cursify/slant option does not work. It moves the glyphs sideways, but it won’t actually slant them. I tried x-height and 1/2 x-height to no avail.

Can you do a screen recording of what you are trying?

Yes, I can, but when I want to upload the file, it says that I cannot upload the file, because it is prohibited

Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif, woff, woff2, ttf, eot, pdf, zip, glyphs, txt).

You can simply zip it (Right click > Compress…) and upload the zip.

:roll_eyes: Ahh… Of course.

This is a screenshot pic: It shows what happens when I slant/cursify. The left sidebearings change to -451, but the glyph itself does not slant: (1.1 MB)

and here is the movie

It looks like you are slanting components? (Or have you disabled the nodes?)

I disabled the nodes: it works faster when kerning.
Is it that? I’ll give it a try!

And, no, it doesn’t work. I have enabled the nodes (foreground) and it still just changes the right-sidebearing, but does not cursify/slant

Also I noticed that when I want to enable or disable nodes, Glyphs crashes. I thought it was just this font, but I tried two other fonts and the same thing happened.

Screen Recording 2022-05-16 at 13.58.31 (1.4 MB)

Here is a screen recording of Glyphs app crashing when enabling/disabling nodes.

Did you send the crash report that comes up when you re-open the app? And if you do, add a link to this thread and send all of them. And add a small note that you send them as only can search by time (Microsoft bought the crash reporting tool and messed it up). Thanks.

Hey Georg, I did send all the crash reports. The latest crash was caused by trying to add a guide. I sent the report, with my name and a link to this thread

I found your crashes. Thanks. It is a bug that I couldn’t solve, yet. I’m working on it.

Thanks Georg!

The crash should be fixed in the latest cutting edge version.