Glyphs crashing on open


#1

Every time I try to open Glyphs now, it shows me a window saying that I have an old version of the vanilla library. I already updated it, but it continues to show up. Also, besides showing me that window, it shows me the ‘Problem Report for Glyphs’ (and it makes sense, ok, because it has just crashed), but won’t let me open or click in any other window. Also, many items in the menus appear greyed out. When I try to click on ‘ok’ or ‘update’ on the ‘You have an old version of the vanilla library.’ window, it crashes and closes.

56%20PM

36%20PM


#2

What happens when you press OK? Does it crash? And can you send a crash report? And what version of Glyphs do you have?


#3

Version 2.5.2 (1169). It seems it’s working now. It just opened, without any issues. If it crashes again I’ll send you the crash report. But it was crashing when I tried to press or click on anything in the ‘You have an old version of the vanilla library’. window.


#4

It just crashed again. It seems unstable.

I’m sending you this crash report now:


#5

Please read this:
https://glyphsapp.com/tutorials/crashes

Maybe you can find out whether the cause is contained within the user (like a plug-in) or systemwide.


#6

I had the same problem last week. After a few attempts the update must have worked because it stopped crashing. I couldn’t figure out what was causing it.


#7

Will try that! Thank you!


#8

I was having a problem with one particular .glyphs file. Everytime I tried to open it, the program crashed. Now I removed all the plug-ins via plug-in manager, restarted Glyphs and it’s working fine. I will install all plug-ins, until I see any problem, then I’ll know which plug-in might be crashing Glyphs, then, I’ll let you know.


#9

Just to let you know, the culprit is the ‘Show Glyphs in Label Color’ plug-in. When I activate it, restart glyphs and try to open a .glyphs file, Glyphs crashes.


#10

Does it crash with specific .glyphs files? If so, could you send it to me?


#11

It stopped crashing, but if you still want to have a look at it I can send you now.