Glyphs crashing when exporting variable font (intermediate layers)

Hi Forum!

I’m trying to export variable subsets of my font through instances. It usually works but this time it crashes the program. I tracked down the problem and it’s due to some intermediate layers I have in the figures shaped as a 4; if I remove the intermediate layers, it exports just fine.
Any clue how to make this work with the intermediate layers? I’m attaching images of my setup.
(I’ve double checked the names of the excluded masters, the active instances and their order.)

Thank you in advance!

Bug Sagittaire 2

Sure it’s not related to the Disable Masters parameter you’re using?

Side note: for correct VF name table generation, just leave the “Name” field as Regular (unless it’s an Italic). Add a Localized Family Name parameter for a custom VF family name, as well as Name Table Entry parameters to correctly set further entries.

1 Like

I’m sure it doesn’t depend on the Disable Masters parameter. If I remove the intermediate layers from the font, all the variable subsets export just fine.
Thank you for the hint about the VF naming!

But the exports still work fine if you deactivate the Disable Masters parameter? I imagine there is an issue with axis re-ordering not being taken into account for the intermediate layer glyphs. Could you inspect what STAT table you get when exporting without the intermediate layer glyphs?

1 Like

Yes, all the instances (variable and otfs) are otherwise exporting well. I think the problem could just be that the intermediate layers specify a coordinate that doesn’t exist when I suppress one of the axes. I don’t know how to inspect the STAT tables.

Did you try the latest cutting edge version?

1 Like

I have found a workaround for myself by using a different construction and avoiding intermediate layers, but thank you for the help. :slight_smile:
In case anybody reads this thread looking for answers about the disable masters parameter, it works a charm even in 3 axes setups now, but the masters involved in the export must be moved at the top of the master list in the info panel. I couldn’t find this info anywhere else so maybe it’ll be helpful.

The Disable Master parameter should work fine in the latest cutting edge version.

1 Like

Oh wow now it exports everything at once, wonderful! Thank you so much <3