Glyphs don't fit in window

Hi: In my GLYPHS-version 2.5.2 (1186), the single glyphs don’t fit in window?! Every time I click on a new glyph, it looks like this:

Pretty sure this is the same issue reported yesterday, here:

I saw the same problem yesterday when I updated to 2.5.2 (1186). There were also a couple of times when I couldn’t type anything with the text tool. I had typed several words to see them in preview. When I tried to change the words, I got the “bonk” error sound the Mac OS gives when it doesn’t like the keyboard input. Eventually it worked, but I don’t know what series of clicks got it past the problem. Another thing I saw was that if I tried to double click on a glyph in the preview below, it wouldn’t move me over to that specific glyph. I would have to scroll over manually to edit it. I reverted to 2.5.2 (1181), and Glyphs started working as expected.

What happens if you press cmd+0 (zero)?

Then the glyph fit. But the problem still occur …

So the initial zoom/position is wrong? Or is it not working later?

For me, if I clicked on a glyph, the window would appear empty, with no metrics lines visible. If I zoomed out, the glyph and metrics guides were there, but positioned further down than usual.

Yes, the zoom/position is wrong. In addition: When I work with a glyph, sometimes the nodes don’t react when I try to move them via my keyboard?

I think I can reproduce this. Happens always after I typed in a number field of the grey info box at the bottom. Temporary workaround: switching to another tab and back again fixes it.

Thanks :wink:


Similarly, if I double-click a glyph in the preview bar to “open” it (i.e. make it the active glyph), I would expect Glyphs to pan/zoom to this glyph in the edit area, especially if the glyph is outside the visible area. Practically like pressing cmd+0. If I am not mistaken, this used to be the case in earlier versions.

Now I’m using Glyphs Version 2.5.2 (1184) …

Same here.
Using Glyphs Version 2.5.2 (1186) on last El Capitan as well as the latest High Sierra.

As described in another thread cmd-a, cmd-c, cmd-v, and arrow keys do not work.

Unresponsive key phenomenon:

The update for the keyboard shortcuts is up. The initial zoom is not fixed, yet.