Glyphs error

I got this error when running the Glyphs Export script in FontLab:

File "<string>", line 5
    <!DOCTYPE html>
SyntaxError: invalid syntax

What could be wrong?

CDid you make sure you have the latest version?

Looking at the script again, it seems you have not installed the .py correctly. Because line 5 is a comment and no HTML.

Yes, I should have the latest version, I copied the script from schriftgestalt (Georg Seifert) · GitHub today and copied the file “Glyphs” into the FontLab Macro Folder as instructed and it is selectable (see screenshot). But it doesn’t work.

It is the first time I load a Macro in FontLab …

Now I got this:

File “”, line 0
SyntaxError: unknown encoding: utf8
File “”, line 0
SyntaxError: unknown encoding: utf8

Well, for “unknown encoding: utf8” I found some threads here in the forum …

@Ferdi You wrote that you “copied” the script from Georg’s repository. It needs to be downloaded rather than copied, along with the other scripts that are in the .zip file, then uncompressed and the Export script you want to use has to be copied into the FontLab Macro folder.

When you want to use it, it is Run from the FontLab Macro dropdown on the FontLab Menu bar. Then it should work.

@George_Thomas Sorry, “copied” was my bad expression, I did as you described above.

Probably I have some bad Unicode names in my .vfb

Heureka! I tried once again, and finally it worked. Thanks for trying to help me.