Glyphs is unresponsive

I have a question. I cannot open the Glyphs app after installing an update.
It’s really unresponsive. The icon doesn’t even jumping at all :sweat_smile:
I tried to force quit it several times and restart my laptop several times too but it doesn’t help. What can I do?

What version of Glyphs do you have? And what version of MacOS?

I am using Glyphs 2 version 2.6.7
and my mac is still on mojave :sweat_smile:
version 10.14.6

Can you try this version: ?

Same issue for me.
Glyphs 2.6.7 - OS X 12.4

Yesterday, a popup has been displayed, saying to download Python. I did it but, from that point on, Glyphs has stopped opening.

Just tried Glyphs2.6.8-1361, unfortunately it hasn’t solved.

Screenshot 2022-05-18 at 9.30.52 AM

Instead, Glyphs 3 opens correctly, though it doesn’t load scripts.

Thank you.

it’s still cannot be opened. the icon was bouncing at first, but after a while it froze and unresponsive again

Have you removed all plugins (from ~/Library/Application Support/Glyphs/Plugins)?

Plugins removed, now it works for me!
Thank you.

Unfortunately, in Glyphs 2, the Macro window displays this message when I try to execute a script:

Screenshot 2022-05-18 at 10.23.02 AM

yess finally! it works for me now. Thank you so much :grinning: :+1:

@ninis are you able to execute scripts?

I haven’t try to execute script yet. Is it obligatory? I’m in a beginner level of using glyphs so I’m still unfamiliar with the most of features :smiling_face_with_tear:

Ok, don’t worry, scripts are not mandatory, but they could be very useful, among other things, to speed up your work by automating certain tasks.

@PaoloBiagini You need to install python and pyobjc: Glyphs 2 on Monterey | Glyphs

1 Like

Great, now it works fine!
Thank you again.

Great thankyou! I’ll keep it in mind :smiley: