Glyphs keeps crashing every couple minutes

Hi there,
Glyphs [3.1 (3133)] keeps on crashing, sometimes 5 minutes after reopening, sometimes as soon as 20 seconds. I keep sending bug reports, whenever the program closes. I could have something to do with my file (which I created in the newest version as well) that contains a couple corner components. A different file (without corner components) seems to work fine, but I have no idea if it has something to do with this.
I run macOS Monterey 12.5.1 on an M1 Max chip and I’d be glad to share crash reports/logs if I am told where they are located.

Thank you in advance,

Can you re-apply you license file?

I did that, unfortunately the crashes keep occurring. I thought the »Crosshair On Select« plugin caused the problem but it continued to crash even after deactivation.

Can you start without plugins? Hold down the Option and Shift key when you start the app.

Try the steps described in the Crashes tutorial.

@GeorgSeifert The Option + Shift Key didn’t work for me (neither from the dock nor the programs folder), but manually renaming the Plugins folder worked, but still the program kept crashing (now without plugins).
@mekkablue I always send crash reports with my email attached but so far no one has reached out to me. Also the window to send the crash report doesn’t always open up after it crashed (maybe every third time or so).
I have a strong suspicion that it has something to do with my file, but so far I haven’t gone ultra crazy with any features except for corner and cap components and as said before this file was created with the newest version of Glyphs so I doubt there is any conversion bug.

Can you please send me the .glyphs file to support (at) (this website without ‘www’ or ‘forum’). I will have a look.

Can you try the latest cutting edge version (active it in Preferences > Updates).

@mekkablue I just sent it.
@GeorgSeifert I updated to 3.1.1 but after a couple minutes the crashes kept on occurring.
Again, thank you for your help!

I was able to open the file and keep it open without issues. Perhaps it is not the file after all.

Have you tried the steps in the tutorial? What were your findings with opening the file in a different user, deleting autosaves, etc.?

What you need to send is the one that comes up after you restart the app. The one that has the Glyphs icon in it.

I’ve been working in a different file for over an hour and encountered no problems, after going back to the file I sent you, 5 minutes into working it crashed again. I’m sorry I am unable to pinpoint the cause of the problems more accurately, but crashes only occur when actively working in the file (moving points, creating new shapes, working with the scaling of components… maybe just keeping it opened doesn’t cause the crash). The amount of time passing between reopening the file and it crashing varies dramatically (20 sec up to 10 min) and so far I have not been able to discover one particular action that causes it (like moving a point with the cursor instead of the arrow keys, which I initially thought it to be).

I know what the crash-report-send window by Glyphs looks like, it just doesn’t show up regularly (depending on the type of crash). Scenario A: Glyphs disappears without warning and the option to send the crash report by Glyphs shows up after reopening the program, Scenario B: Glyphs freezes and the macOS loading cursor appears (there is no Glyphs crash report window but from time to time an Apple crash report window with the option to send information appears).

Can you do a screencast of one work session until a crash? Hopefully one that is not 10 min :wink:

@lucas1 sorry you are going through this, I know it is a pain. But would you please answer me this one question:

Do these random crashes also occur in a different user?

I think the problem is solved now, I’ve been working in the mentioned file all evening and no crashes occurred. I’m not entirely sure what fixed it, but here’s what I did:
I followed the tutorial sent by @mekkablue on crashes yesterday but none of the suggested solutions worked for me. After updating to the latest cutting edge version today I decided to retrace these steps from the tutorial (this time with 3.1.1) and after deleting the com.GeorgSeifert.Glyphs3 the crashes stopped. I did try many approaches almost simultaneously but I think that’s what did the job in the end.
@GeorgSeifert I’m not sure if it’s still helpful but I uploaded the video of a crash I recorded yesterday that happened repeatedly every 15 seconds (that’s how I knew to start recording: every time I opened Glyphs I performed the same steps and it always crashed while dragging one node with the cursor—as seen in the video—it was getting rather comically). Perhaps it is of any use for you.
I am really glad it’s fixed—thank you sooo much for your help! :innocent:

Do you still have a copy of the pref file in the bin?

You don’t happen to have a copy of the preferences file you deleted? Maybe in Time Machine? There was a setting that would trigger the crash that is now disabled. If you would enable it again, the crashes might start again.
But I’m happy that you can work at least.

And please send me the screencast.

Sure, it’s still in my bin—I’ll send it to your support email address. I’d be happy if this helps you in any way, please let me know if it does :slight_smile:

The video starts when I reopened Glyphs: Bildschirmaufnahme 2022-08-19 um on Vimeo

Again, thank you so much for the prompt assistance!

Nevermind, unfortunately since I wrote the last message it crashed 3 times. :sob:

I recorded another video of the two types of crashes I described earlier, one happening after the another in the same recording:

They only happen when dragging around points (as I did a little exaggerated in the video), so maybe it is caused by the file and not my settings of the program? They also occur when I start Glyphs without any plugins.

Hi there,
I follow this position with great interest, since I hesitate to buy Gliphs soon. In this regard, I have two questions:

  1. Why, on your video, are the moved vertices connected to a rectangle in the background?
  2. Is Gliphs truly compatible with M1 or M2 chips?
    Personally, I also work on Mac M1…