Glyphs Lagging and Loading slow on Macbook Pro

I’ve been live-streaming type design on Twitch, using OBS and Glyphs simultaneously. In the past, I’ve had no issues with the two, but recently I can hardly zoom, scroll, move points, etc. without painfully long lag times.

Running Glyphs App Version 2.6.5 on macOS Catalina 10.15.5 and the most recent version of OBS. I don’t have any plugins installed for Glyphs, and only use 1-5 characters in the preview as I’ve read that might slow it down.


I’m preferences select to use latest Glyphs 2 beta, It’s quite stable.

Can you try to disable plugins by holding the Option and Shift key when you start the app?

Make sure the plugins are up to date, yes.
Verify in Activity Monitor which app is taking up most CPU.

Hey Georg, I’m not currently using any plugins.

OBS uses a substantial amount, but it has always. The combination of Glyphs and OBS was working fine a few weeks ago, but now I have to wait 30 seconds between every other click in glyphs.

Double digit entries are suspicious if not for apps that are in front or in direct use. 74% seems OK if you make a recording at that time. It is not okay if it is just in the background. What about Glyphs when you run it?

A plug-in can also interfere if it is just loaded, even if not activated by the user.

There are several other big CPU consumers in the list. Did you update any of the components or the OS recently? How does it list look if glyphs is running?

Do you have any plugins in Glyphs. Can you try starting without them (hold down Option+Shift when you start the app).

I don’t have any plugins installed, let alone activated. In the screenshot posted before and the two below Glyphs is running, but shows either 0.0% CPU up to 9 or 10%, sometimes dipping into the alert, “(Application not responding).”

Here’s another one while streaming:

And again only moments later:

It may not be a glyphs issue, but Glyphs is the only application that lags so horribly while other applications, like Adobe XD or Illustrator, run smoothly.

I don’t see glyphs in either screenshot. How does it look when you are working in Glyphs. Can you try to make a spindump of a short session working in Glyphs. (start it from the gear button in Activity Monitor). It will produce a very long text. Send it as a .txt file per email to support at this domain.

And what is Chrome doing? It is using almost 80% CPU? And Google Drive another 28% So Google alone is using more than full core.

can you post a screenshot of the Memory tab in Activity monitor?
and how much RAM do you have?
there might be something eating up all your memory, possibly Chrome.

Chrome: is it possible you have a lot of tabs open and not exactly the latest version of Chrome?

In other words, does Glyphs become slow too when OBS, Chrome and Google Drive are off?

I’ve sorted the issue out for the past two broadcasts! I usually use Google File Stream to host my files and don’t generally have a problem with it. During one stream, during a big lag in Glyphs I noticed the autosave file updating in a Finder window. I think the internet usage of uploading a live stream and maintaining live files was too much.

So the solution has been to move the Glyphs file I’m working on on stream to my desktop, and Glyphs runs smooth as butter! Thanks for the help and trying to solve the issue, it seems to be internet connections/Google File stream load related.


Thank you, that is very useful information. Considering a tutorial about increasing performance and will mention this finding.

1 Like