Glyphs License Problem

Hi, I bought a new Glyphsapp license, but it doesn’t seem to be working, I tried the troubleshooting tutorial, the license worked only when I added a new mac user, but I don’t know how to make it work on my user account!

Please advise

  • A

Have you tried the installation via the Terminal command too?

No, I don’t know how to do it, is there a short summary on how?

  • A

Make sure is in the Applications folder. Then try these steps:

  1. Create a copy of your .glyphs2license file on the Desktop. Rename it to file.glyphs2license
  2. Open
  3. Paste the following text, press Return:
sudo /Applications/ -disableUI 1 "~/Desktop/file.glyphs2License

When it asks you for your admin password, type it (attention: you will not see password bullets), and press Return.

Now open Glyphs, and open Glyphs > Registration. You should see your name.

After typing my password it says

sudo: /Applications/ command not found
Ahmads-iMac:~ ahmattu$


is it maybe because my app name is “Glyphs 2”


The terminal thing didn’t work, but by just doing step 1. I tried dragging the “file.glyphs2license” to Glyphsapp while it’s closed, and Voila!! it worked :smiley:

Thanks a lot @mekkablue