Glyphs Mini - Automatic kerning doesn't change

Hi folks! I’m working on my first font with Glyphs Mini 2 and I came into an issue I don’t find a solution for it. I already created all the latin and cyrillic letters and I see that some of them (such as groups) automatically take the kerning of a specific letter. For example Â, Ä, À and so on. I put a specific kerning on the letter “A”, but the following combinations of the letter I mentioned don’t take the right kerning of it. I also tried to put Group “A” bellow the kerning, but still doesn’t work. And it is the same with other letters, not only with “A”.
I know that Glyphs Mini is limited, but is there a solution for it?

There groups are not created automatically. Instead, the left and right Group names are used:

Initially, no kerning group name:

Bildschirm­foto 2022-11-18 um 16.31.25

Set a kerning group name, for example, “A”:

Bildschirm­foto 2022-11-18 um 16.31.39

Other glyph does not automatically get kerning value:

By defining the right kerning group of Á to also be “A”, it uses the same kerning on the right side as A does.

Thank you for your answer. Unfortunately doesn’t matter if I define the right and left kerning by a Group “A”, because it doesn’t change anything. Here is an example with pictures of my work file:
Screenshot 2022-11-21 at 13.38.44

And have you defined the kerning to the group or to the ‘E’ directly. You ca check in the kerning panel. If the pair has a ‘@ E’, it is group kerning. Otherwise it is glyph kerning.
The easiest solution is, after you added classes to all glyphs, to use the “Compress” option from the lower right button in the kerning panel.

Thank you for your response!

I only defined the kerning to the group of ‘E’. After your comment I also tried to add’ @ E’ to the kerning itself. Unfortunately nothing appeared in the Kerning Panel. How do I add pairs to the panel? Sorry, I’m novice in the program and still learning.

You need to define the kerning groups for all letters that belong to the group. This means that the kerning will change for all group members regardless of which glyph you edit the kerning values in.

In your specific case that means: write “E” as the kerning group(s) for the E as well as for È, Ē, Ë etc., and the kerning will work.

Side note: the left kerning group can probably named H, as your E is probably identical to the H on the left side.

You can find a concise, easy-to-follow tutorial here: