Glyphs Mini from App Store is not working


#1

I recently purchased Glyphs Mini from Mac App Store and it’s not exporting my font correctly.
When I click to export, it takes a while then it says Exported Successfully.
However when I go to install the font in the native app Font Book, it just shows squares and not the letters, my font is also not recognised in any other app after I install it.

This bug occurs on 2.0.1 (79) version. The curious thing is, if I download the trial glyphs which is 2.0.1 (74) my font export perfectly, without any error, and I can use it in all my apps. I work with a strict deadline and have to rely in the trial version now to export my font.

I tried to uninstall and redownload from App Store, and same problem.

Is anything I can do? Can I somehow downgrade my purchased version from the App Store back to (74)?
Could I receive a license to activate the trial (74) version? I feel really sad because I paid for the app and it’s not working. Please help me.


#2

Can you send me the .glyphs file? And what version of MacOS do you have?


#3

Do not use Font Book to test your fonts. This will cause a font cache problem. Read this please:
http://www.glyphsapp.com/tutorials/eliminating-font-cache-problems

Better use the Adobe Fonts folder:
http://www.glyphsapp.com/tutorials/testing-your-fonts-in-adobe-apps


#4

Hello Georg, i sent the glyphs file by email. My Mac Os is the latest version High Sierra.


#5

Hi mekka. Sorry but that doesn’t make any sense. I don’t use Adobe, i only work with native Apple apps like Pages Numbers and Font Book and Font Book works correctly with Glyphs 74 but Glyphs 79 is not working, the font gets broken when exporting from 79 and no one app recognizes my font.

Edit: i tried to follow the “solution” to delete font, clean cache etcetera, and it doesn’t work. Even if i create a new name for the font it works only for v74, not v79.


#6

Fair enough. If you don’t have Adobe apps, you can try our TextPreview tool, which circumvents cache problems. Really, do not install a font in macOS unless you consider it completely finished and thus are not going to change it anymore.

Does it work with Mini v.82?


#7

My boss uses the font in real time and it requires constant edits so he can see how the font progress appear in his project. I could even rename the font name if that helps, but unfortunately this doesn’t matter in v79 because even a new brand name gets broken.

I saw you said about the v82 but the Mac App Store comes in the v79 and there is no way to update it.
Also the trial version comes with an updater and the Mac Store version doesn’t. It’s really strange.

Edit: Unless there is a manual way to update it. Could you send me the v74 too?

Another thing i noticed is that only the trial version generates the files inside the temp folder, the purchased version is not generating files there, looks like the export module of the purchased version is not working.


#8

Can you try in a different user? Sounds like write permission problems.


#9

You forgot the v74 trial version can write just fine. And I’m already using administrator user.
Is there a way to manually update/downgrade my app from the App Store?


#10

This has nothing to do with it. There can still be permission problems. Have you tried in a different user? It would help exclude some potential error sources.

I don’t know, what I found on the internets was this answer: https://discussions.apple.com/thread/6655364?start=0&tstart=0


#11
  1. There is no other user, only the admin user.
  2. The trial 74 works.
  3. I purchased the app and it already came with version 79, there is no “backup”.

Unless someone point out how i can manually downgrade or update the app through the files/folders the only thing it works for me is the trial version. The problem is i already used 30 days of my trial and decided to purchase the app because it worked in the trial, now that i purchased i feel cheated cuz it doesn’t work lol.
I’m using another trial on another machine just to circumvent the problem while i can get a solution here. If no solution will appear i may have to ask a refund since my purchased doesn’t work while the trial does.


#12

We can give you a temp license until the AppStore build is fixed.

Please: Can you try creating another user (via system preferences) and try there? You can delete the other user again. It would really help finding the root of the problem, because it allows us to rule some potential causes out.

And can you send your .glyphs file to support at (this domain), please? We are trying to reproduce the problem.


#13

I’m working on a new version that fixes this. The problem has to do with upper plane characters.


#14

@Georg - Thanks a lot Georg. Can i hope thisfix will be available before my second trial expires? I don’t have another machine to get a third trial, i think i have 20 days left on my second trial (using in an alternative machine). I also could give you my apple receipt from the purchase if you need.

@mekka - yes i sent the glyphs file to Georg, the same one that works in (74) but not (79). I still have 20 days on the second trial, i hope the fix can be done by that time.


#15

Hello. Can you please give me the temp license until the AppStore build is fixed? I would appreciate that a lot. I work everyday in fonts and I don’t want to risk losing days of work. I hope you understand. Thanks.


#16

Sent you an e-mail.


#17

Thank you :slight_smile: I will use the temporary license while the app is not updated on the Mac AppStore.


#18

Hi. Just a heads up, the AppStore updated to the new version 2.0.2 (87) and I updated my review to 5 stars to reflect the fix. Thanks again for the fix! You can close this thread if you wish.