Glyphs not in standard alphabetical order

Hi. I want the glyphs to display in English alphabetical order. Right now they are in what seems to be an arbitrary sorting. Please advise.
Thanks, CM

Glyphs Manual, Page 204 (Chapter 17.4.1) has the information you need. You would be most interested in the “sortName” field to set up your own sorting order. Just make sure you don’t use a sorting system that conflicts with the master data file.

Is this an imported font? Take a look at File > Font Info > Font and see if there is still a glyphOrder parameter hanging around, and if so: Delete it.