Glyphs taking all CPU and super slow

Hi, I updated yesterday to the cutting edge version 3.1.1 (3140), I’m on Big Sur 11.6.5 Mac Mini M1 2020, 16 GB; and suddenly Glyphs is barely responding. I get the spinning rainbow with every click and can barely do anything. Pre-update files seemed to be allright so I imagine it must have to do with the update. Crashed twice already too :confused:

Have you installed any plugins? Can you try to start without them by holding down the Option and Shift key when you start the app?

that seemed to have helped - however the one that was the most recent to be installed (and could be heavy on the system I suppose) is Kern On and I definitely need it to progress with work further

The plugin is processing the existing kerning. If you open a font with a lot existing kerning, it takes some time. But you might get in contact with @TimAhrens. He might be able to help.

I see - that makes sense - thanks @GeorgSeifert!

If you like to use KernOn, it might be better to remove the existing kerning and start over.

Yeah - I’ll have to speak to @TimAhrens – I’m working collaboratively and I think between two machines KernOn lost some information and that’s what was causing the issue retrospectively. But on the other one it seems to all be good so we’ll finish there and try to nail down the problem afterwards. Perhaps it was a combination of system/glyphs updates? anyway - should be a different topic I suppose :slight_smile:


Not sure what was going on when Glyphs crashed.

So, you are saying that simply having Kern On installed makes Glyphs very slow on start, or even crash? That’s strange. Kern On doesn’t do much unless it is explicitly started (using Edit > Kern On).

@GeorgSeifert : As far as I understand, the only code that is executed is the loadPlugin method? It’s rather lightweight, and I don’t see any potential for a crash in there. Other than that, it shouldn’t have any impact unless it is running.

Hey @GeorgSeifert & @TimAhrens, not sure if that is a Kern On issue in the end. I’m working on another typeface and have no kerning data at the moment. The issue occurs when I have more than one glyphs file open. The moment I load up another file ANY click brings up the rainbow wheel - switching tabs, tools, switching between characters. The issue started after updating I believe from the 3.1.1 (3136 or 3137) to the latest 3.1.1 (3140) version. It occured before, on the previous version of the system (Big sur 11.6) and it was the same after updating to the latest (Monterey 12.6). Starting without the plugins seems to help. The plugins I have installed are: Kern On, Metrics Solver, RMX, and SyncMetricKeys (there are also: BlindFold - not on during the issue; LabelColor - not on; Reporter Toggler - on by default all the time; Stem Thickness - switching it on and off didn’t help, as any other plugin installed via glyphs plugin manager - I was only using the Master Compatibility, but that on/off did not help either).

Can you remove the Metrics Solver and see if that helps?

The issue is still there :confused: Should I restart after removing? or is there any further need for a clean-up?

Yes. Restart Glyphs. If it is not solved, remove the remaining plugins one by one (restart Glyphs every time) to find the culprit.

Hello @GeorgSeifert - problem solved!!! It was the SyncMetricKeys plugin - after removing it everything seems to be working fine. I suppose that it works in the background and somehow started working between two files maybe? It was definitely a recent/new issue.

Thanks for all your help with this!