Glyphs Viewer with Glyphs 2.4.1 and iOS 10.1.1

The Glyphs Viewer app doesn’t show anything to connect to.
Well that’s about it. Is it a result of the new 2.4 (2.4.1?) update or the app itself (or iOS 10)?

Did you make sure both devices connect with the same speed to the same wifi network?

Same network, of course. The speed i haven’t check. Will do soon.

Mac: Opt-Click the Wifi menubar item, check the PHY Mode
iOS: I don’t really know. Anyone?

It doesn’ t work for me neither. Mac OS 10.9.5 on Lan + ipad iOs 9.3.5 on wifi

Doesn’t work neither on 2.4.1 on macOS Sierra 10.12.1 and iOs 10.1.1. But it doesn’t before the upgrade to 2.4.1. Can’t remember last time it worked.

I tried it yesterday in an office with 5/6 people working on Glyphs, and the only glyphs that show on the app are those of an old version of Glyphs. All the remaining (up to date) computers show a blank page on the phone…

I checked again with few other networks and on most of them i can see that there’s a Glyphs App opened but the Glyphs Viewer only shows a white page, no drawings.

What happens if you open an edit view and do things there?

And can you send me your appleID. Then I can send you a beta version of the next version of the viewer.

Nothing’s happening in edit view, just a white screen on the iPad.
I’m sending a DM with the ID.

No. I mean you should start working normally in the edit view. And maybe you did refuse access. Please run this in the macro window:


Yes, i understood and did just that. Moving points, drawing new paths doesn’t help.
I run the code, restarted Glyphs and tried again but it’s still the same.

The Beta works fine.

Only it doesn’t take line breaks into account, so there is only one long line and it’s not very convenient to find a letter or preview a short text with a few lines.


Yes. It is meant as a quick & easy preview and not made for long texts. For long texts, I suggest exporting into the Adobe Fonts folder.

I’m having the same problem (Glyphs 2.4.1 956, Mac Os 10.11.6, iOS on iPad 10.2 14C92)

I understand the “quick & easy preview” but any chance of updating it with paragraphs?
I don’t have retina displays on my macbook or iMac, is not the same as testing
on InDesign.