Glyphs wont run after GlyphsGit install

I tried to install GlyphsGit plugin as described in its readme. After that, Glyphs wont start (I’m using latest cutting edge version and 3.0b version)
I removed the plugin from plugins dir and repositories dir, restarted Glyphs, but it still wont run.
I tried to start it without plugin and it works.

Any idea on the issue?

I just looked at the GitHub repo; that is a very old plugin (2015) so it’s not too surprising that it has problems.

Report it on GitHub as an issue.

1 Like

I updated the plugin to the latest API and send a pull request.

1 Like


@GeorgSeifert I have reset Glyphs by removing both repository and plugins folders, I reinstalled modules from Glyphs’ preferences, now I get this after installing any plugin (I’ve sent many reports by email)

It happens with any plugin I install. (I have the latest cutting edge version installed)

Can you run this in the Macro Panel and post the result:

import sys

Here it is:

2.7.16 (default, Jan 27 2020, 04:46:15) 
[GCC 4.2.1 Compatible Apple LLVM 10.0.1 (clang-1001.0.37.14)]

what about this:

import objc
print(objc, objc.__version__)

Here it is:

(<module 'objc' from '/Library/Python/2.7/site-packages/objc/__init__.pyc'>, '5.3')

That is the wrong version. It needs to be something like this:

(<module 'objc' from '/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC/objc/__init__.pyc'>, '2.5.1')

You should be able to delete /Library/Python/2.7/site-packages/objc/ and then it should work.

When I remove the named folder I get this error:

Traceback (most recent call last):
  File "<macro>", line 3, in <module>
ImportError: No module named objc
Traceback (most recent call last):
  File "<macro>", line 1, in <module>
  File "", line 8, in <module>
   import objc
   ImportError: No module named objc

is “/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC/objc/” in your path?

No, I tried to add it via terminal but no success

Somehow you disturbed you python installation. I can’t do much for the current version of Glyphs. The next will better handle this.

1 Like

I think so, I’ll see how can I reset my python installation and figure a solution out.
Thanks anyway