Glyphs3 plugin error in M1 Mac OS 12.3

After installing Glyphs3 on M1 Mac OS 12.3, we installed our own plugin. Every time I start the app, I’m told to install a universal version of the bundle because it doesn’t include a version for the current Architacture.
The same error occurs when you try installing python 3.9.1 and installing the plugin in the Repository folder. How can I solve this?

Have you check that the plugin does include a universal binary? How did you build the plugin?

What is a universal binary? It works well with other Mac OSs. There is an error when installing the plugin in M1 OS 12.x only.

How did you build your plugins?

The M1 Macs have a different CPU architecture that all Macs from the last 20 years. Those need different binary executables. To make it easier, you can put the M1 and the intel binaries in one file. This is called Universal Binaries. Universal binary - Wikipedia

If you have a Mac with a different MacOS, it will have a different CPU type. So the difference is not the version of MacOS but the CPU

The plugin was built using GlyphsSDK/Python Templates in github.
Downloading and installing the General Plugin does work with the same error.
How do I check if Universal Binaries are included?
if it is not included, How can I include it?

What branch Of the SDK repo did you use? It has to be the ‘Glyphs3’ branch.

I used the one on this link.

On this page, there is a ‘master’ button. Click it and select ‘Glyphs3’.

I’ll switch it that ‘Glyphs3’ is the default.

1 Like

The plugin now works fine. Thank you.