Glyphs3. Run .py files problem


I have a script file. I want to install/run it.

Run Glyphs3 → Script menu → Open scripts folder. Opens the Finder with the Scripts folder. Copy my file into this folder. Restart Glyphs3.

Script menu is empty.
What am I doing wrong?

The script needs an appropriate header, like this:

# -*- coding: utf-8 -*-
from __future__ import division, print_function, unicode_literals

Checked. Everything is correct.

(is part of the whole code, of course)

The code doesn’t look right. In what app did you open the script?

File opened in TextEdit. I don’t know the code rules and syntax’s. I’m a Glyphs3 user.

I might be that you downloaded the script as html instead of just the script. So when downloading it from github, you need to clock the “Raw” button with the Option button pressed.

I ran this script in Glyphs2. Can you check it? My file link

As you see in the preview in the dropbox link, you have indeed downloaded a html version of the font. Re-download the plugin as described before.

1 Like

Thank you!

The script is part of the mekkablue scripts. I recommend you install them through Window > Plug-in Manager > Scripts. That has the advantage of Glyphs keeping it up to date automatically.

1 Like

Thank you!