Gray boxes in Font view tab act strangely

I’ve been confused by the behavior of the font view for a while. It’s not a big deal, but I’m hoping somebody can explain :slight_smile:

My understanding is that “Glyphs with unsaved changes show a slightly darker glyph cell until saved” (from the handbook.)

Instead, what I usually see after hitting CMD-S to save is that the gray boxes that are currently visible turn back to the normal white background. But, if I scroll the font list down, I’ll see other glyphs with a gray background. Usually, I can repeat this 2-3 times before I reach the end of the font list.

Other times, after I save I’ll switch masters and see gray boxes reappear.

Most confusingly, sometimes when I cold-start Glyphs and open a project, I’ll see glyphs with the gray background from the start! If I hit CMD-S they’ll go away, but then the project files will apparently have new changes (I use git to keep track of my work.) This is unexpected because I didn’t make any edits; I literally just opened the project and hit CMD-S without doing anything else. (Peeking at the diffs, looks like changes to glyph widths and component positions.)

I’ve tried to make a screencast to help explain, but unfortunately I can’t reproduce these issues reliably. When they happen, it always takes me by surprise, but it happens often (2-3 times a day.)

Are these bugs, or is there something about the font view that the handbook isn’t telling me?

Which version of Glyphs are you running? There used to be a related problem, but I believe it was fixed some time ago.

Version 2.4.4 (1075) on High Sierra. I’ve been working on this project for a looong time, though… probably started it under 1 point something.

Hmmm. I cannot reproduce this, and haven’t experienced anything recently.

Would be interesting to know which ones. I can imagine auto-aligned compounds getting updated.

Here’s the changes I noticed this morning (cold-started the app, noticed unsaved glyphs, hit CMD-S)

It looks like Glyphs was catching up with a bunch of spacing adjustments I made yesterday. All of these glyphs are components or compounds.

Is there some sort of housekeeping routine that runs when a project is first opened?

EDIT: It just occurred to me that I possibly committed my changes in git last night before shutting down Glyphs. (I’m pretty sure I hit CMD-S before running git commit though.) These may be changes that happened when I shut down the app. I’m still not clear on why they showed up as unsaved changes when I opened the app this morning… does Glyphs look at my git project status or something?

Thanks for the help!

PS: Here’s a screencast showing the other weird behavior (gray backgrounds not going away after a save.)

This can happen when the automatic alignment of those glyphs acts up. It should only happen to glyphs with components. Could you send me the file that I can have a look.

Oh yes, now I remember I had a similar problem once when I discovered that there was a circular reference in the metric keys.

I sent a link in a private message. Thank you!