Gray malformed shaped in edit view

I’m having an issue where weird gray shapes are displayed over the glyph in edit mode. They’re somehow related to the curves of the glyph, but I can’t figure out what I did to enable them, or if they’re a bug of some sort. This behavior appears in all glyphs, not just the B pictured below. It also occurs in brand new documents, and documents which has no previous issues. Also appears in the glyph preview pane.

Tried uninstalling and reinstalling, copy and paste from one document to a new one, deleting the glyph (Glyph > Remove Glyphs) and adding a fresh one (Glyphs > Add Glyphs…), as well as the usual restarting my computer.

Working on a Mac with Yosemite 10.11.6; Glyphs Version 2.3 (895).

Thank you!

Well, the issue appears to be solved. I removed from the /Applications folder, and deleted these folders:

  • ~/Library/Application Support/Glyphs/
  • ~/Library/Saved Application State/com.GeorgSeifert.Glyphs2.savedState/
  • ~/Library/Preferences/com.GeorgSeifert.Glyphs2.plist
  • ~/Caches/com.GeorgSeifert.Glyphs2/

I then downloaded a fresh copy of the Glyphs app (ZIP’d) and unzipped/installed it. Upon opening the application, the glyphs began displaying correctly again. I hope this helps anyone else with this issue.


You might have had installed a reporter plugin in ‘~/Library/Application Support/Glyphs/Plugins’. Buy nuking everything, your got rid of it.