Grid Subdivision value reset on reopening


I’m working with 10 points in Grid Spacing and 10 points in Subdivision through my preferences. I have saved my .glyphs file with this setting. When I close the file and reopen it my Grid Spacing remains on 10, but my Subdivision field resets to 1.

Resetting the value each time I reopen the file is not a problem, but some components end up shifting, and some nodes set on decimal locations shift to the nearest factor of 10 on the grid.

Is this a bug, or have I overlooked something?

Thanks for your time.

This is clearly a bug. Will fix it.

This is fixed in the latest beta that I uploaded just now.

Thanks Georg! Much appriciated.

Bumped because I thought would be a similar problem.

I’ve just updated to 1.3.19 and noticed that now with 10 points in Grid Spacing and 10 points in Subdivisions I can only move nodes to positions that are a factor of 10. I’ve tried different values and have the same problem. The values are not restarting on reopening now though.

Have I hit a bug like last time or was there something new added that I may have missed?

Fixed it.

Thanks Georg,
I’ve updated again and now the problem’s gone and can move nodes back to positions with a factor of 1.