Hand Tool issue


I updated to High Sierra (Not sure if I had the same issue was in Sierra, too).

I am experiencing a problem with the Hand tool. When I want to use the Hand tool too quickly, it is “jumping back to the same spot”. Usually when I am zoomed in.

It is probably not the mouse, because I tried it in Indesign and also with Glyphs on a different computer, and it works fine.

Thank for a help in advance.


Testing it in Indesign is not going to tell you much as it handles mouse events totally different.
What kind of mouse do you have?

My mouse is Razer Diamondback.

But I recorded a video when using the Hand Tool with apple trackpad (bluetooth) and it is doing the same.
trackpad.zip (1.8 MB)

Are you in Text Mode and switching to the Hand tool by holding down the space bar? You may be typing a space when you do that, and then it refocuses to where you typed it.

You could prevent that by holding down Cmd before pressing space, and releasing it immediately after you push down the space bar.

It is doing the same with spacebar and also when I am using the hand tool alone (activated with the icon).

When I press Command with Spacebar, it changes to the Zoom icon.

I cannot reproduce this with my mouse on 1089 in High Sierra. Can you try and reproduce it with a different mouse?

Yes, but then you release the Cmd key and keep holding down the space bar. It will change back to Hand tool. The advantage is that you do not type a space in the process.

Non of the above suggestions worked for me.

But I found out, it is not the Glyphs app problem. The problem is, when you have the Dictation in OSX turned on. I turned it off and now the mouse (and trackpad) works as before.

Anyway, thanks for the quick feedback!

1 Like