HatchOutlineFilter breaking changes

Hi, I thought I’d go back and look into a plugin I’ve been working on at

One of the things it did was split a shape into two, whereby the two shapes were stored in layers, then the lower layer was supposed to get a HatchOutlineFilter-effect.

Now it no longer works and the layer returns as empty. It looks like the layer is “orphaned” somehow when I log it and get: <GSLayer “orphan” (orphan)>.

So I thought I’d ask if there’s been any breaking changes to the HatchOutlineFilter since June this year?

Usually the orphan <GSLayer “orphan” (orphan)> is an idicator that the layer has no parent. By default it has not. Simply set the glyph as it’s parent, and it might work.

(Without looking at the code, but maybe a hint)

I’m really just using the layer here as a container for the shapes, when the function returns, it takes the shapes from the layer and adds it to the layer that’s not an orphan.

The problem is that the layer is empty, there are no shapes in it when I run the HatchOutlineFilter-effect.

I seem to remember that the Hatch effect worked in earlier versions of Glyphs.

I thought I’d fire up my old computer, and the HatchOutlineFilter seems to work there. This is why I think there might have been breaking changes introduced in a later version of Glyphs.

Skjermbilde 2023-10-14 kl. 14.04.05

And here’s how it looks at a later version.

Screenshot 2023-10-14 at 14.09.07