Having problems installing file in Font Book

I recently made a custom (handwritten font) with Glyphs, and it seems to export just fine, but when I install in via Font Book, I get missing letterforms.

That is difficult to understand without the font file.
And did you read this: https://www.glyphsapp.com/tutorials/eliminating-font-cache-problems ?

I did. Ran through all the necessary steps provided in the blog post. I can provide the font file here if you’d like

I am pretty sure this is a font cache problem. Have you tried exporting it with another name? Please DM me the file if that didn’t work either.

I’ve cleared the font cache a few times. I’ve also created an Adobe Fonts file. It seems now that the font has serious problems (tried to validate the file before installation). Will DM the font file

I had a look at the OTF you sent me. Technically, the font is fine, installs fine, and works fine. But I do suggest the following:

  1. Disable hinting at export time, i.e., turn off the Autohinting option in the Export dialog.
  2. Add lowercase letters, figures, punctuation and symbols. Your font does not have any lowercase letters yet, or more generally, it has no support for any characters besides uppercase A-Z and space. The missing letterforms in your screenshots are the missing lowercase letters and punctuation such as comma, period, etc.

If the font is unfinished, do not install it in the system yet. Use the Adobe Fonts Folder instead, and test what you have in InDesign.