Highlight Seems To Be Off On Exported Font (HELP PLEASE)

Hey All,

Trying to figure out why the highlight is off on my typeface.

My settings are:
Cap Height: 1000
x-Height: 500
Ascender: 1050
Descender: -50

And all my characters are aligned to the baseline/top of the cap height. Everything else is working superbly just can’t figure this out. Is this an Alignment Zone issue?


Hi Alex, which app is this?

1 Like

Hi @mekkablue This is in Illustrator

In Adobe apps, the selection rectangle usually is as high as the font bounding box. Which leads me to assume that you accidentally have raised the baseline of this text box in Illustrator. What are your text settings?

Can you try in different apps (Photshop, web browser)? If I remember correctly, Illustrator calculates the “font height” on some key glyph. Are the lowercase glyphs empty?

All lowercase glyphs are empty yeah. Is that why? Also is there an easy way to copy all the uppercase glyphs into the lowercase fields? @GeorgSeifert

Looks like this in Photoshop

Hi Alex, regarding your second question, there’s an active community on this forum so a search can be very helpful: https://forum.glyphsapp.com/search?q=copy%20uppercase%20to%20lowercase also be sure to check out the robust tutorials and Glyphs Handbook for your own reference.

Delete all empty lowercase, select all uppercase and tun “Glyph menu > Update Glyph Info”. That will assign the unicodes of the lowercase to the uppercase, so you get the uppercase glyphs if you type lowercase or uppercase. That should fix the selection.

@GeorgSeifert Does this mean they’ve been deleted/removed?

Also not seeing the Update Glyph Info in my glyph menu.

select them all an actually delete them.

when I select them all and press delete nothing happens. also not seeing a delete/remove glyph option in the menu. Sorry I’m asking 10000 questions.

EDIT: I found it. didn’t realize it was the minus sign on the bottom
Is update metrics the option you were referring to?

For future reference, there’s also the menu Glyph > Remove Glyph (Command-Delete) for deleting glyphs.

The other thing Georg mention is also in the Glyph menu as Glyph > Update Glyph Info. Remember to select the glyphs before selecting that menu item.

@composerjk thanks for the info.

Still not seeing that menu item.
Is there something I’m doing wrong?

You are using Glyphs Mini. The then you don’t need to do anything.

Tried that and rexported/reinstalled the typeface still having the same issue.


Please read this: https://www.glyphsapp.com/tutorials/testing-your-fonts-in-adobe-apps

Yes. This is probably a font cache problem. Read this please: