How to automatically add unicode values?

I’ve created all four types of small numerals (numr, dnom, sups, subs) with RMX Scaler, not via “Generate Glyphs” menu. So now they don’t have unicode values and don’t show up in corresponding categories in font apps.

P.S. It won’t even allow me to add unicode manually. And neither generating glyphs manually adds it. That’s not good is it?

According to the OT specs, figures with dot suffixes like .sups are not supposed to have separate Unicodes because the name before the dot is already taken by a Unicode-linked glyph. You do not need to be able to type them if you use OT features, because you access them via the feature.

If you want separate (sometimes legacy) Unicodes applied, then you should use “onesuperior” etc. (no dot suffix).

However, you can override this behavior if you check File > Font Info > Other Settings > Don’t use nice names. But unless you know exactly what you’re doing, I do not recommend it.

BTW, to find the right glyph name for a Unicode, go to Window > Glyph Info and type the Unicode in the search field: