How to change segment order

Hello hello!

I presume a simple question, but I can’t find the answer anywhere:

In a situation like the picture below, when ‘Correct path direction’ doesn’t solve the problem, how do I fix this?

Take a look at Filter > Fix Compatibility, also described in section 5.2.1 Fix Compatibility of the Glyphs 2.3 Handbook:

I this case, open the Paths menu, hold down the option key and press ‘Correct Path Direction for all Masters’.

@composerjk Thank you, that’s exactly what I was looking for!
@GeorgSeifert I had already tried it for all masters separately, but that didn’t work. Doing it your way also doesn’t have the desired effect.

Or copy, delete and paste the top outline.