How to clean duplicated nodes in batch


#21

Hm? Just tried again and Tidy up paths also removes zero-length curve segments for me.


#22

The problem is something else. You have a lot of single-segment paths:

Technically, it is MOVETO-CURVETO, which usually is displayed as two nodes. Just get rid of these. Good way is the Delete Small Paths filter, from Window > Plugin Manager, with a threshold value of approx. 15.

How did you create these paths?


#23

Thanks for taking a look however I’m seeing something different on my end. Take this ‘W’ for instance, none of these errors are single segment paths like in your example:

06

They all seem to be zero-length curve segments for me with at least three nodes. And tidy up paths seems to have no effect.

The paths were created in illustrator using autotrace.


#24

The paths are so bad that I would consider ditching them and inserting new ones.

  • Get rid of the smallest ones. Anything below 100 square units is microscopically tiny and can hardly be displayed.
  • For the ones that are left over, consider redrawing with line segments (i.e., no curves).
  • For the ones you do not want to delete, fixing these zero segments goes like this:
    1. Hold down the Option key and drag-select the red point. This selects only the on-curve points of the segment.
      get-rid-of-red-segments-1
    2. Option-Delete to delete the segment. This also breaks open the path.
      get-rid-of-red-segments-2
    3. Double click to select the whole path.
      get-rid-of-red-segments-3
    4. Move it left-right with the cursor keys: this should close the path again. (Alternatively, right-click and choose Close Open Paths from the context menu.)
      get-rid-of-red-segments-4

#25

Ok, I’ll try a few things, thanks for your help!