How to get rid of dimmed lines in overlapping contours on Glyphs 3?

Hi there,

I began using Glyph 3 last week and I don’t like how lines are dimmed in overlapping contours. Is there a way to visualise them in the same was as in Glyphs 2?

Also, HT Letterspacer UI is not working on Glyphs 3. Any idea on how to solve it?


Works for me:


Try uninstalling and reinstalling both HT Letterspacer and Vanilla through Window > Plugin Manager.

Thanks! I did but it still doesn’t work. I’ll dig deeper later.

What about the dimmed lines in overlapping contours? Isn’t possible to visualise them like in Glyphs 2?

I have been looking in the source code, but I think the only way around this at the moment is a reporter plug-in.

My advice is to let it sink in for a few more weeks. It is a good indicator for path direction issues, and so far most people got used to it quite quickly. If it is still an issue after that, I can help you with the plug-in.

There is a setting to disable the remove overlap preview. I’ll look it up.

1 Like

Please, let us decide on this. I need to draw and modify overlapping contours and it’s difficult to see them well with so little contrast.

The gray outlines should still be quite visible. Can you check your screen color calibration?

To change the setting use this line in the macro window:

Font.previewRemoveOverlap = False

Thanks, but I ran it and re started but nothing changes (and the dimmed lines are not very visible TBH).

Screen Shot 2021-07-05 at 19.54.34

After running the code, you need to re-open the doc or change anything in a layer to trigger an update (move a node back and forth).
Did you save the file before re-opening the document? It will not ask you to do it on closing.

Yes! Now after the second time I re started, it worked. Maybe an option in Preferences for a future Glyphs version?

Screen Shot 2021-07-05 at 22.31.57

1 Like

I agree, It’s a cool feature but sometimes its hard to see them. Would be great to have it as an option as other stuff like show/hide nodes.


FWIW I also dislike the dimmed lines, too similar to paths in the background layer.