How to handle these accented letters?

I am having some trouble making these accented letters to work. Does it need exporting acutecomb with -300/-400 LSB?

В чужо́й монасты́рь со свои́м уста́вом не хо́дят.

are these even used? and how?

This tutorial should help: or this:

You can also copy each of them into the Glyph > Add Glyphs… dialog, perhaps space-separated. Make sure you have acutecomb (or acutecomb-cy if you want it to be different from the Latin one) in your font, and the base glyphs have top anchors.

That is how I have been using Glyphs since the beginning. However, please export a font or use already exported one and paste the cyrillic string that I have mentioned and see what you get. On my end it shows no glyphs, or shows the accents next to the glyph instead of on top of it.

In the tutorial, it says that Glyphs should handle combing accents on its own and retract the sidebearings. Should I also negative space the LSB (about -400 LSB)?

Combining nonspacing marks should have zero width. Also, they should be shifted left (i.e., have a negative lieft sidebearing) so they can sit above an average letter. That is meant as a fallback for when the mark feature doesn’t work.

Also maybe my string is broken. Is there a different string I can use?

But: In the .glyphs file, you do not need to set the width of combining accents to zero. You can let the app take care of that: At export, Glyphs will automatically retract the LSB to the RSB. Makes editing easier, and you only need to take care of the RSB. Hurrah!

The negative sidebearing is not actually needed. The accent will be positioned by mark positioning and for that, you need the anchors as described in the tutorial.

It works for me as expected. I made a rectangle font, the acute being a small rectangle, and I pasted your sentence in InDesign:

The only thing that matters is your RSB. The LSB will automatically be retracted to your RSB. This is explained in the text you quoted from the tutorial.

So choose an LSB that is convenient for you to work with (hint: probably not negative).

What do you mean?

I meant that the string might have contained accents that are not possible, since it was grabbed from the web.

Thank you both, I will experiment with the sidebearings. You guys made a lot clearer than what I thought before. Also appreciate you testing it out.

Just ignore the sidebearings of the accents…They really don’t matter.

Okay, I might need some further assistance.

I made the accents to work somewhat. Setting the RSB to /zero. However, they appear on the rightmost side of each letter when I try to add them with Character Viewer. I think they should appear in the center as showed in Glyphs anchor preview.

The setup seem to be correct.
Where did you try this? Can you send me the .glyphs file and the .otf? And the test document, too.

Probably not the fault of the font, but the app: I assume mark attachment was disabled or does not work in the app you are viewing it with. If you want it to sort of work in those cases, you need to find an RSB value so it somehow ends up more or less in the middle on most letters.

Also, check for an accidentally added space between z and acute. Copy the text and paste it in UnicodeChecker > Utilities Window (Cmd-2) > Split up.

Excellent tip. It shows that I have two accents added in the Split Up, would that mean that my app is not supporting this?

Also If I mess around with negative RSB, would that screw anything?