How to PUA encode an existing font?

Hi, I just started creating fonts very recently. I created a font but someone who wanted to use it in MS word can’t access the ligatures. How do I make that possible? I understand that they need to be PUA encoded but I can’t figure out how.
I tried creating a new glyph named uniE000 but what after that?
I’m terribly confused.

Don’t rename your glyphs. Activate Use custom naming in Font Info > Other settings. Then just type in the unicode in font views lower left info box.

But Word does support ligatures (I tested the Word for Mac v15) and it should be the same on Windows.

That is not true. For ligatures to work, they need to activate OT features in Word:

It is not a good idea to apply Unicode values to ligatures.

That creates a separate glyph called uniE000.
Read this please: https://glyphsapp.com/tutorials/unicode

Hey,

But I tried using it in MS word as well and I can’t use ligatures either. They work fine in Adobe Ps and AI and even Mac’s pages but not MS word.
The ‘text effects’ in MS Word also show the ‘ligatures’ greyed out.
I’m not sure what could be wrong here.

this is how it looks in my office:

You may have a font cache problem: Https://www.glyphsapp.com/tutorials/eliminating-font-cache-problems

Hey,

I don’t think its a font cache problem because the ligatures work fine in Adobe PS and AI as well as Mac’s pages. It just doesn’t work in MS Word and the option to change text effects in greyed out.

Can you send me the .glyphs file? To support (at) (this website without www), please. I will have a look.

And can you send a screeshot of the settings dialog from Word? And what version of Word do you have?

Hi, just sent you the file.

Hi, here is a screenshot.
Also, I just realized that a few of the letters are also cropped from the top on MS. why could that be?

I’m using the 2016 version of MS Word. I got it today itself just to check because the user said he couldn’t use the ligatures on Word. I’m using it on a Mac.

The glyphs are cropped because your vertical metrics are wrong. https://glyphsapp.com/tutorials/vertical-metrics

  1. File > Font Info > Font > Custom Parameters: lots of conversion artefacts, you can delete all of the parameters there.
  2. File > Font Info > Font > Features: Delete all features, then click Update and Compile.
  3. All your glyphs are 250 units above the baseline. If this is not intentional, select all glyphs and try Filter > Transform > Transform with Translate Y: -250.

Then, export as TTF, autohinting off, overlap removal not necessary (no overlaps in the font), install, and it works as expected, provided the respective settings are made in Word:

I think the problem was that no default languagesystem was set. For word, all GPOS feature rules need to be registered in a languagesystem.

Hi,

I did all of this and I also tried changing the font name and restarting my computer as suggested by @GeorgSeifert. Still not working for me.

Also, I am working on another font that has ligatures and I checked but its not working in MS Word either. Just not sure what am I doing wrong here.
The ligatures seem to be working fine everywhere but MS Word.

I had someone test it on a Windows computer as well as its not working for them either. Even the character map doesn’t show the ligatures.

I’ve also tried clearing the cache as mentioned in the article on this website.

Did you select the text before applying features?

Hey,

Not sure what you mean. Do you mean if I selected the text in Word? Yes, I did.

Also, if you mean if I selected the Glyphs before applying the changes, then I did that too, even though I think that wasn’t really needed. But I tried it when nothing worked.

Can you send me the font you exported?

The font I was able to export (as described above) worked without a hitch in Word.

Yes, I’ll do that.
I asked for the font @GeorgSeifert exported as well and I just checked it. It doesn’t work either.
I’ll send you the one I exported on support.