HT letterspacer bug

When I run HT lettersspacer the marco panel says this:

Config file exists

Traceback (most recent call last):
  File "HT_LetterSpacer_UI.py", line 15
    HT_LetterSpacer_script.HTLetterspacerScript(ui=True)
  File "HT_LetterSpacer_script.py", line 544, in __init__
    self.config = readConfig(self.master.name)
  File "HT_LetterSpacer_script.py", line 232, in readConfig
    newline[4] = float(newline[4])
ValueError: could not convert string to float: 'H'

I had this same issue at first. I’m pretty sure I managed to stop getting this message by not using – and deleting – the default config file provided and creating a brand new one through the UI prompt instead. If I remember correctly, I also hadn’t set up the custom parameters with values entered either so that was causing an error.

Hi, this is quite a common issue with the old HT Letterspacer, you need to rebuild the config file.

Just as a tip, you can find a rewritten module (with a UI) in the plugin manager: HT Letterspacer Manager. You can the use the scripts in eweracs scripts > HT Letterspacer (also available from the plugin manager) to run HT Letterspacer. I apologise for the current bugs in the HTLS Manager, I don’t have the time to work on it right now, but I appreciate any issue reports.

1 Like

Thanks, deleting the config file worked