Huge issue when opening Glyphs

Hello everyone,

I’m having huge issue when opening Glyphs. I’m currently the last update (which I updated a few hours ago) and when I open Glyphs or any glyphs file, I automatically get the crash report window. Even when force quitting, reboot my computer nothing works. I just can’t create a new file, opening an old one, access settings or anything. Any hint on what is happening ?

Thanks for any help on that as you might guess, it’s highly urgent for me to be able to use Glyphs!

Well it looks like I had trouble with the show stem pro plugin. Removed the repo folder from my plugins and Glyphs seem to be working again.

Sorry to hear that.
If you later have a spare minute and dare to try to re-install the plugin to see if that problem occurs again, I would love to hear about either outcome.

Can you reinstall the Show Stem plugin. Maybe you had an old version?

It’s ok, I was a bit scared at first. I activate that plugin. It crashed and I couldn’t reopen any glyphs file. Remembering it was the last thing I did, I uninstalled it and it worked. I’ll try to install it a bit later, I really need my Glyphs to work haha

I’m quite sure I had the latest update. I’ll reinstall it anyway!

I still have occasionally users for who the plugin manager’s automatic update does not work.
Just recently I remote-debugged someone’s plugin, and the bulletproof method to print out the user’s plugin version did never match anything close to the currently most up to date version on github.

The plugin manager seem to not always fetch the latest version.

Once the user manually removed (from the plugins and repositories folders) and re-installed the plugin, it was finally the latest version.

Unfortunately this is something out of my hand, and I reported that. But so far I was told that the plugin manager might only have a lag of maybe a day or so. Apparently in some cases that still doesn’t hold up. Sorry for the inconvenience there.

Thanks a lot for the explanation, that’s really helpful! Good to know that the plugin manager may have a delay with auto-update, I’ll be less panicked next time I get such a bug! Cheers

But surely feel free to contact me in any case of an issue with my plugins. Often it is just a hiccup, but as often, I might have a quick solution. I am aware though, that you initially could not know where the crash came from.

Also let me know if it crashes again, once you dare to install it again :slight_smile:

Sometimes the plugin manager gets stuck and can’t update at all. It is tricky to debug.