I cannot launch the application

(I bought a license today)
(MacOS Big Sur 11.3.1)
Everything worked at first. Then I needed to download some plugin, but python (runtime or smth) was not installed. I clicked to install it and restarted Glyphs, then it didn’t open and now the following message began to appear:

What should I do to solve this?
I tried uninstalling and reinstalling, but it didn’t work.
Please help.

Can you remove the plugins? They are in ~/Library/Application Support/Glyphs 3/Plugins/

When you remove them one by one, we might find the culprit that is causing the crash and we can fix it.

The thing is that I haven’t Glyphs folder in the Application Support folder.

I don’t know why, because I did not manually delete anything from there

The Folder should be “Glyphs 3”. And are you sure you are in the right Library.

You can temporarily disable plugins by holding down Option +Shift when you start the app. That should give you a chance to remove the plugins from the plugin manager.

Oh, I really was in the wrong library. Now found the plugins folder and removed the Red Arrow, this one was there. But nothing has changed, the window still appears at startup.

I also have this, maybe something here:

Yes, I removed python and now the glyphs are running. Does this mean that I can’t use the plugins at all, because python doesn’t work?

Can you update to the latest cutting edge version (activate it in Preferences > Updates)?

Then install Python and the plugin again.

O! Now it works, thank you!