Ignored text wrapping / Icon font

I set up an icon font from a blank glyphs document and placed all my icons in PrivateUseArea. Everything works good after exporting the font. But I recognized in Indesign (in AI it works) that the text wrapping doesn’t work as usual. When I shrink my left-aligned text field, my icons don’t jump to the next line. The field appears empty. When I expand it again, the font is displayed correctly. Maybe I have to set special user parameters in the font info dialog? Are there always constant parameters that a font should have? Thanks for your help!

That has probably to do with the word wrapping properties. You can try the same with any text. Type something without spaces, make the text box small enough and disable hyphenation.

I don’t have defined glyphs for ».notdef«, ».null« and »nonmarkingreturn«. Now it works in Indesign.

The first two shouldn’t be needed (the .notdef will be added automatically), but it would be the first time that I heard about “.null” had any purpose.