Illustrator import coming out strange

I’m making a dot font - it is completely made in illustrator and I’ve now imported it into Glyphs. The problem is some of the dots are coming out slightly warped when I move the paths.

It’s strange - not all of them just one in three or so. It is one side is pushed in or out slightly.
They are perfect in illustrator - get pasted perfectly in glyphs, but when I move them (as a group) one or two will react strangely.

Fullversion - latest update.

When I say move them I mean select all then hold shift and arrow keys as well as moving with mouse.


Update: I’ve now tried making the dots straight in Glyphs and moving them and again they sometimes get screwed up when moving.
The size of the dots is 17.71points across (about 6mm)

What happens if you set the grid (font info > other settings) to zero and then move the paths?

Thats done the trick. Thanks!
Putting subdivision to zero as well made it work.

Dammit. After re-importing 6 masters worth of illustrator paths I find that again this is happening even with the grid turned to zero.

It’s happening less now, than before but still my circles are coming out squashed slightly.

Can you send me the AI file with the path that is not copied properly? support at glyphsapp dot com

Precisely what happened to the paths?

Can you post some screenshots from before and after it screwed up?

I’ve noticed this second time, that the glyphs now look normal in glyphs app but when exporting them they get wonky.

The first one is illustrator before pasting. Then Glyphs. Then the font in action. (all closeups)

This is do to rounding applied to the coordinates. But it should not happen if you set the grid to “0” (you need to move the cursor out of the text field or hit enter after setting it to zero).

Also to be considered:

  1. Your path directions are wrong. Layers > Correct Path Directions on all glyphs.
  2. Can you check if it’s perhaps two paths exactly on top of each other? Technically, that would be an overlap. At export time, Glyphs tries to remove overlaps, and these distorted paths may be the result of that.
  3. Is it possible that these circles are very small? At rasterization, curves are processed into short straight segments called subpaths. For Postscript outlines, there is a technical limit to how many subpaths can be displayed, and that limit can be reached quickly if you have many very small curved elements in a glyph.
  4. Is it always the same circle? Consider drawing only one circle and reusing it as a component.
  1. I corrected path directions, this actually made more of the dots come out badly.
  2. It’s not two paths on top of each other - checked that.
  3. The circles are about 18 points across.
  4. The original design in illustrator was all based off one original circle.

mmm… thats odd.

Now I’ve noticed in illustrator - when I make the font into outlines, suddenly the circles go to their normal round shape as displayed in glyphs.

Here’s an example of the font - Regular and Bold. The problem being in the regular version.
It’s an optical sizing font so I have smaller versions of these with less dots but still the same problem.

So, this is a display problem of the font renderer that Illustrator uses. It tries to optimize the screen display of fonts, but is just not built for this kind of small element. All you can do is make sure you have no hinting at export time. So, don't worry, it's just a screen display problem.

I’d still do it with components, though.

Thanks for that. Unfortunately I printed it out and it prints the same way illustrator displays it.

I’ll look into the components thing - but this probably wouldn’t solve the display problem would it?

Also, how do I make sure there is no hinting at export?

Thank you.

Can you send us the Illustrator, .glyphs and .otf files to support ( at ) glyphsapp . com?

When you export, make sure Autohint are both unchecked.
And in this case, I would also leave Remove Overlap unchecked.

I haven’t checked all the masters yet, but it seems turning off auto hinting and remove overlap has resolved this problem. I’ll check everything and let you know.

If it’s still a problem I’ll email you the files Georg.

What version of Glyphs do you have?

The latest one. Turning off auto hinting and overlap fixed the problem.

From App Store or direct? What build number?