I'm unable to download the app


I’m currently in the Republic of Georgia.
I’ve tried Chrome, Safari, and Firefox.

This has been discussed before. Only certain computers are affected, and we have not been able to reproduce it. You can try any of these three workarounds or solutions:

  1. Download on a different machine.
  2. Change your DNS servers to or and try again. Works for some people.
  3. Inspect, and if necessary, fix your Hosts file. You may need to restart your Mac or at least log out and back in after this. This is most likely the solution for the problem if you have been using system optimisation and connection management tools like MacCleaner or CleanMyMac or Little Snitch.

And of course, if you are still using these kinds of tools, please uninstall them.

Please let me know if any of these worked for you.

Edit. Related issues discussed in these threads:

I just solved this problem by using iPhone to visit the download link, and then using Airdrop to send the zip file to my Macbook, it works! Finally! (Glyphs3 2021)