Import from Fontlab = duplicate glyphs


Long time fontmaker, first time attempting to import a font from Fontlab into Glyphs.

I successfully exported from Fontlab using the instructions here Porting to Glyphs | Glyphs
and turned off “Keep glyph names from imported files”.

But the imported font has two each of most of the punctuation. It won’t let me delete them because they’re used as references to other characters. But the weird part is that both versions of the character give the same error, as if they’re both referenced. Here’s an example:

And trying to delete the hyphen to the left of it gives the exact same error message.

And I can’t even export a test font without resolving the problem for all characters.

Thanks in advance for any help,


You can also rename it or disable export. If you want me to take a closer look at the issue, you can send me the FontLab vfb to support (at) (this website without www).

One possible reason could be that you had one glyph ‘hyphen’ (without Unicode) and one ‘uni002D’ (with Unicode). Glyphs renames the latter to the readable name and creates the duplicate.

I would rename the one without Unicode to ‘hyphen.alt’ until you sort things out.

if it was just one character, i’d work around it, but it’s pretty much all the punctuation characters. I emailed the files to mekkablue.



I had a look at the files you sent and it is pretty much as we suspected: The FontLab file contains 27 duplicates, carrying the same name, but once with and once without a Unicode assigned. The export script preserved that, of course.

Thank you! So I see them in fontlab – they’re grayed out/empty but they’re there. I selected them and hit “delete” – it asked if I wanted to delete 27 characters, I said yes. Then I re-exported, but they’re still ending up in glyphs.

Did you get it to work?