Imported UFO from Fontlab » Classes/Features are sending Syntax error "'" missing while compiling

Font won’t export because of it.
Do you know what could be?
a’ aacute acircumflex adieresis agrave aring atilde

This above is an example of one of the classes

sub @LC by @SC;
and this one of the simple Features.

Any thoughts?

syntax error at “’” missing
No File was created. The Reson is unknown.

This is what outputs.

It “’” is used in FontLab to define kerning classes. It should be removed on import.

I would need the .ufo to really now whats going on.

Can you go to font info > feature and click the compile button. What is the error message?

You will need to go through the feature code and fix it.

Do I need to remove the apostrophes from the classes definitions is that it?

I removed apostrophes from classes tried to recompile it but received no output nor error message, saved file as .glyphs, tried exporting font, but glyphs crashed everytime I tried.

Hi Georg. Still no luck with the export. I’ve sent you the UFo through email. I wasn’t sure on the RoboFab release, sorry.

Can you delete all entries in font info > Font > custom parameters?


I tried it, still couldn’t export the .otf. Same output error Syntax Error at “’”. No file was created. Reson Unknown.

Is there a class or feature without a name? Or more precisely, with “” as its name. Try clicking right under the last feature name. If there is a nameless class or feature, delete it.

Hi, I am also running into that problem (syntax error at “’” missing)
it seems like this thread was not resolved. Any advice to fix that problem? thanks


That can’t be resolved automatically. You need to check your feature code. The features are stored quite differently and thous it sometimes need some adjustment.

ok I am looking into it, thanks for your prompt answer

I´m having troubles to compile my features because a similar error:

syntax error at “,” missing

Can you help me out?

Did you import a .ufo, too?

Please check this tutorial:

Solved! thanks!