In G3, the marks aren't variable

In G2, the marks worked correctly in variable fonts.
Apr-30-2021 05-01-53
But in G3, the marks are fixed. (Based on the first master)
Apr-30-2021 04-50-49
The file is not saved in format 2.
And now I can not go back to version 2,
G3 disappointed me, unfortunately!

Can you please send me the .glyphs file to support (at) (this website without ‘www’ or ‘forum’). I will have a look.

I sent it by email.
please help me.
My deadline is next week.

I had a look at your file. The problem is that you disabled the grid and those floating point positions and some rounding errors messed up the variable mark positioning. As you don’t have fine details and as variable fonts don’t support fractional coordinates, I would strongly recommend to set a grid of 1.

And please close some of your tabs.

I set the grid spacing to 1. And created a file with only 2 glyphs (one letter and one mark) and reset all positions.
But the problem was not solved!
The exported VF of this file from G2 works properly.
I sent this file to you.

The problem was solved by rounding the coordinates of the anchors.
Complicating matters was the fact that version 3080 had a problem in variable font export.
I had to test with version 3.0.2 .which also had problems with variable font marks (and I did not know).
@mekkablue made version 3079 available and I fixed the problem with it.
Thank you all

1 Like