Including .fea file in 2.4.2

Good morning guys,

Tal Leming’s cookbook got me into the idea of streamlining family creation by using a single external feature file in multiple fonts (and the web designer in me has a fetish for compiling multiple files into one upon export, so it seemed like a great fit).

Now since 2.4.2 implemented include(); support, I tried it out right away, but am getting some strange results. When I compile before export, everything seems fine. When I try to export, however, I get the following error:

If I disable my user-created kern feature, the external calt feature file and a custom feature file I’m trying to include export and work perfectly. As soon as the custom kern feature is enabled (even if it only contains one simple rule), I get the error message, which can also look like this:

The ss01 feature only contains 20 lines, btw…

The strange thing is, even if I use a .glyphs file I saved before I tried implementing the includes (even files that are several months old), I get the same error, and can only export if the kern feature is disabled. If I try exporting the same files in 2.4.1, though, they work, which makes me think this is all a coincidence and that there’s another problem at work here that has nothing to do with the includes.

Any help would be greatly appreciated!! Thank you in advance,


Can you send me the .glyphs file please to support (at) (this website without www). I will have a look.

Sent. Thank you!

Hi guys,

Any ideas why the file’s not exporting in 2.4.2?



Sorry about the delay, I just saw that I started my reply, but forgot to send it off.

There was a problem with kern feature additions when there was no other kerning. But this is fixed now. The file you sent me exports fine in Version 2.4.2 (1059).

Hi mekka,

No problem! Thank you for fixing it. I’ve downloaded 1059 and the file exports (even with the includes).

I noticed I can’t include an external feature file in the kern feature like I can in GSUB features. Is there a reason for this, or rather, a workaround?

Either way, the other includes are already very helpful… Thanks again,


Depends on what you are including. Look inside the Temp folder to see how an include is integrated. You will see you cannot use the feature statement except in the Prefix, etc.