Incompatible glyph


I have a glyph in my font that doesn’t want to export, says it’s not compatible.
I find it hard to find out what’s causing this. I have checked all the nodes, and they are the same in all masters and bracket layers.
The only thing I notice, is that when I select a layer, sometimes the glyph on the layer is not selected, and sometimes it is. Does this mean anything?

Hopefully somebody can help me out.

Thank you.

What do you mean by “sometimes the glyph on the layer is not selected”? Can you post a screenshot?

You need to check compatibility of:

  • anchors
  • components
  • corner and cap components
  • paths (path order, node order)

Yes, hereby the screenshots. I mean when all the nodes etc. are selected. Sometimes it happens when you click on layer, and sometimes it doesn’t. Like you see in the screenshots.
I figured that maybe a glyph is not compatible, when you click the layer but the glyph is not selected.
Hope this makes sense…!


Ah, do you mean you have Edit > Sync Layer Selections (installed via the Plugin Manager) on? That is a good idea:

  1. Select everything on one master; this should select everything on compatible layers as well
  2. Step through the other masters; to speed up the process, consider the Master Switcher palette plug-in, or Edit > Other > Next Layer
  3. If a layer does not show any selection, you know it must be one that is not compatible with the others, and you need to investigate that one further.

No, I didn’t have that on, but it’s a very useful tool! Thank you.
But unfortunatly, even when all layers show selection, it’s still not exporting.
It’s a letter P where the stem, rounded shape and white space are seperate shapes.
When I export them as seperate glyphs they work fine, but when I use them together it suddenly doesn’t work anymore. Any idea what I’m doing wrong? I can upload my file if you want to have a look!

Thanks again.

Are you exporting as static fonts or as variable font?

As a variable font…

Does it export as static font? If yes, then the problem is the TT conversion.

Yes, it does. Also as TrueType. But off course the bracket layers are not included, so there could be a mistake.
Do you have any tips on how to proceed? Other ways of troubleshooting compatibility?
That would be great.

I don’t see bracket layers, only brace layers. Try disabling them (delete one brace in the name), and see if that changes it. Also try decomposing the letter for an export, see if that makes a difference.

Yes sorry, braces, that’s what I meant.
What do you mean by decomposing? I’m not using any components…

Have you tried the “Show Master Compatibly” from the view menu. And you might need to add a “Enforce Compatibility Check” custom parameter to the font.

Thank you for your help, guys. It turned out it was (red of shame), because I didn’t see the possibilty of horizontal scroll in the Fix Compatibility window. That way I could order all the elements right and got it compatible.

1 Like