InDesign v17.2 and gravecomb

It’s not direct.

I have observed the same, a font just not appearing in InDesign’s font menu. Very good detective work, @TrineRask, I couldn’t find out what caused it, but sure enough, if I remove the codepoint 0x300 from the CMAP tables, the font suddenly shows up.

A different font doesn’t exhibit the same problem, though. Contains gravecomb with Unicode, but is still listed in InDesign.

Must resist from ranting about the ever-declining quality of Adobe software …


I just checked some other fonts & I just finished an old typeface and generated it from Glyphs 2.6.5 it doesnt cause the problem though gravecomb with Unicode is included. Can’t find the difference (so far)

Can you send me the two files, the one that works and the one that doesn’t. Ideally you could remove as many glyphs as possible that is still causes the problem. And also try to remove as many OpenType features.

how do I send them? I’m to new to upload attachments

Send a link to the .zip on Dropbox is something similar. Or send it by email to ‘support’ at this domain.

I have sent an email to support, with some more examples.

I must be an InDesign bug for sure.

I found that if you have gravecomb (U+0300), then you need also ncaron (U+0148), and the font will show up again in InDesign. Totally random and weird.

This would break all fonts which contain combining diacritics, but no “Latin Extended” or similar character set. Nice one, Adobe!


You are right, it fixes the problem. I now have a font with A, Agrave & gravecomb that doesn’t work when the unicode for gravecomb is present, but when I add ncaron it works. My other finished custom font that doesn’t work has no ncaron, but the retail font, that I coincidentally generated from Glyphs 2 has it. And they were all working well before the update of InDesign

Does Glyphs adjust OS/2 ulCodePageRange or ulUnicodeRange when you add ncaron ?

I don’t see any change from Glyphs and before I pinned the problem i tried define unicode ranges etc. copying information from well working fonts. For me it could only work by removing the unicode (0300) until Jens discovered the ncaron “solution” I don’t know how @jkutilek discovered this?

Hi everyone, I also have this problem since I updated my indesign to 17.2.
Did you finally find a way to avoid that ? I’m working on an allcaps font so I cannot just add a ncaron glyph…

Add Ncaron with both UC and LC Unicodes. Look for ‘All-Caps Font’ in the tutorials.

It works when you remove the unicode 0300 on the Gravecomb But it’s a quick fix until the problem is solved in InDesign

1 Like

Hi guys, thanks. I just tried both solution (adding Ncaron or removing Gravecomb) and it didn’t work, I guess I do something wrong. But actually I found a better solution for now, I just get back to indesign 17.1 + clear font cache and it works again :slight_smile:

Which other comb accents do you have in your font?

I just spent several hours troubleshooting and clearing font caches before realising that I’m experiencing this bug with several of my fonts.

Here’s the bug on InDesign’s Uservoice tracker if anyone wants to upvote/comment on it:

I’ve added a comment to point them to this thread. Hopefully their dev team sees it.


I had noticed that some fonts containing gravecomb still showed up in InDesign, and then narrowed down the critical character by setting half of the glyphs to no export, then on the font that still worked, setting half of the remaining glyphs to no export, etc., until I found which single glyph (respectively its Unicode) made the difference.


Hooray! This issue has been fixed in InDesign 17.2.1


It’s still not fixed.
I have that problem right now with a font an a client.
Damm adobe
It’s fixed but I have to restart the computer to refresh the font cache