Initial forms not displaying in Edit window

I’ve added initial forms to my font and compiled, updated. I had the initial forms and standard ligatures features toggled on to preview in the text window and it worked perfectly for days but now the initial forms will not appear.

I am on Mac OS 10.14.4 and the latest Glyphs update. I’ve restarted the computer and tried to only show initial forms as well. Nothing seems to be working. See below where the standard ligature show up (Th) but the initial r does not. Confusing because it all worked until just now.


The features init, medi, fina, and isol are not supposed to be called like this in the first place, and are not intended for Latin. (source)

For Latin, better implement it as Contextual Alternates. See this tutorial for details:

OK, but any idea why it wouldn’t preview with the feature turned on when it did show up yesterday?

Also, doesn’t it seem more complicated to set up the Contextual Alternates rather than just naming them init and automatically generating the feature?

read the tutorial - i see the problem with .init :smile:

but still why would the previews not work properly? I did have issues with the previous versions go glyphs doing that but this newest one hasn’t had any issues so far.

The init feature is not supposed to be used like this in the first place. That the menu item has no effect, that may be a bug in the latest beta.