Intermediate layers in composites?

I vaguely remember that it used to be necessary to give composites intermediate layers if the base glyphs have them. Wasn’t there even a script by @mekkablue to automate that?

Is this still necessary, or can I omit the intermediate layers in composites?

I noticed a strange behaviour: My cedillacomb has an intermediate layer. If I switch the preview bar to the corresponding export then at first, it seems to be correctly using this intermediate layer in the ccedillas. However, if I zoom in to edit the cedillacomb and none of the ccedillas is visible in the edit view then the preview bar stops updating the cedilla shape in the ccedillas. If I zoom out again then the preview bar correctly updates the shape in the composites (once I edit them). Is this just a display bug or is it related to the missing intermediate layer?

Shouldn’t be necessary anymore. This was a bug fixed some time ago. I’ll try and reproduce the preview issue later.

For alternates, it’s still necessary, though. Correct?

As in, if a component has alternate layers, all composites that use this component need the same alternate layers.

I don’t think so.

It could be that unnesting components could be posing problems, because I noticed that alternate layers are still necessary as described above, at least when unnesting components upon export.

I’m not sure whether your Unnest Components filter works differently from mine and takes this into account.

Thanks for your help. In any case, there seems to be a display bug in Glyphs. If the ç is too far outside the visible portion of the edit view then it is not updated in the preview bar.

My work-around is to place another ç next to the cedillacomb so as to ensure the preview bar is updated, even though it is not what I am looking at while editing the shape.

@mekkablue This doesn’t work in 3.2.1 (3258):
I have a component with intermediate layers and they’re ignored unless the parent glyph that uses the component has the same set of layers. The Variable Font Preview 3 shows the expected behaviour, but it doesn’t work anywhere else.

Works for me in 3.3 (3309).

  • Variable font export?
  • Where are you testing? Browser or Adobe app?
  • And is the original glyph also exporting?
  • Variable export: yes.
  • I’m testing in Variable Font Preview 3 (works) & Chrome, Illustrator, and FontGoggles (doesn’t work).
  • The component is a _part glyph and doesn’t export. I just tried to include it in the export — it behaves correctly by itself, but not within the parent.

The headlight should remain circular until opsz 50:

Are you using it as a nested component? There are some issues (depending on the export process you choose). If you want, you can try the same export from the latest Glyphs version – you can install both your current version as well as the latest cutting edge version. Just duplicate your current Glyphs 3.app, rename it to something different (like Glyphs 3 3258.app and then update the other app by checking “Show cutting edge versions” in the Updates section of the preferences.

You’re right — it turns out the reason is that it’s a nested component. I’ll try with the cutting edge version, but at least I know what’s going on, which is great. Thanks!