Interpolation doesn't work

Hello everyone,
I am having Issues interpolating with certain glyphs. All points are set correctly and in a seperate file (bottom picture) the same letter interpolates, just not in my actual file.
Does anybody have an idea what could possible be wrong? The axes, masters and instances are also named correctly and the path direction is the same on both letters.

Thanks in advance.

The drawings are not compatible. You must have the same number and order of points. See the tutorial about compatibility:

It’s an older tutorial and the screenshots are outdated but the principles are still the same.

Ah now I get your remark about the two files. Sorry. What I find confusing is that the glyph info says it’s the K but there is an empty K typed next to it. How did you transfer the glyph from one file to the other?

Yes sorry about that. The empty K is indeed confusing and can be ignored. The empty K was a stylistic set as an attempt to maybe fix the compatibility.

The thing is that interpolation works for almost all glyphs (as you can see in the attached picture) apart from a few, so it can’t be a problem with masters and instances.

On the bottom picture on my original post I simply created a new font file, created a weight axes, created two masters, three instances to test interpolation and copy/pasted the »K« and the interpolation worked just fine. So i really dont get what the problem is.

Sorry about all the confusion it’s difficult for me to explain and summarize.

In the last picture it looks like there is an empty maters? Or a brace layer?

I just solved my problem. It didn’t interpolate because the thinnest master wasn’t compatible.
I didnt know all masters have to be compatible in order for two masters to be compatible?
Thanks for the help.

I assume that the three masters are not exactly on one line, and the instances are in reality between three, not just two masters.

Yes that must be it. I didn’t know about that. Thanks for clarifying.